MyBB.support, le portail francophone de MyBB
Déconnexion impossible après mise à jour vers 1.2.10 : une solution... - Printable Version

+- MyBB.support, le portail francophone de MyBB (https://mybb.fr)
+-- Forum: Traduction francophone (https://mybb.fr/forum-7.html)
+--- Forum: Anciennes versions (https://mybb.fr/forum-24.html)
+--- Thread: Déconnexion impossible après mise à jour vers 1.2.10 : une solution... (/thread-480.html)



Déconnexion impossible après mise à jour vers 1.2.10 : une solution... - spyto - 19-12-2007

Salut,


Ce message devrait intéresser tous ceux qui ont fait une mise à jour de MyBB vers la version 1.2.10 !!!
Ils doivent inévitablement rencontrer tous le même problème.


Suite à une demande perso de LDB qui se trouvait dans l'impossibilité de se déconnecter avec le message suivant:
"Votre ID utilisateur n'a pas pu être obtenu pour vous déconnecter. Ce peut être à cause d'un script Javascript malicieux qui essaie de vous déconnecter automatiquement. Si vous essayez de vous déconnecter, veuillez cliquer sur le bouton 'Déconnexion' dans le menu du haut.", je me suis penché sur la question...

Je lui avais suggéré de faire une modif des templates comme indiqué dans un de mes posts précédents:
http://www.mybb.fr/showthread.php?tid=390&pid=1999#pid1999
Mais ce que j'y préconisais et qui fonctionnait parfaitement pour la MAJ vers 1.2.8 ou 1.2.9 ne fonctionne plus avec la 1.2.10 !!!


J'ai testé en local; j'ai fait une mise à jour de 1.2.9 vers 1.2.10 et effectivement, il est impossible de se déconnecter !!!


Je suis reparti sur le post de Chris Boulton
http://community.mybboard.net/showthread.php?tid=26083&pid=176431#pid176431
Contrairement à ce qu'il y annonce: il semble dire que le "Revert" (Retour à l'original) ne soit indispensable que pour le template "index", mais même après être revenu à l'original pour ce template "index", les problèmes d'impossibilité de se déconnecter subsistent !!!


J'ai donc regardé de plus près le code logout de la v1.2.10 dans les templates: il a complètement changé !!! Rien d'étonnant alors à ce que ça ne marche pas !!!...

En fait, le code de logout était:
- avant la 1.2.8:
Code:
member.php?action=logout&uid={$mybb->user['uid']}
- à partir de la 1.2.8, il est devenu:
Code:
member.php?action=logout&uid={$mybb->user['uid']}&sid={$session->sid}
Autrement dit un n° de session était passé en paramètre au script, sans quoi on ne pouvait se déconnecter !

- et pour la 1.2.10, c'est complètement remanié !!!! Chris Boulton aurait pu le signaler !!!
Code:
member.php?action=logout&logoutkey={$mybb->user['logoutkey']}

Voici les templates qu'il faut, soit modifier pour qu'ils s'accordent avec la 1.2.10, soit remplacer par ceux de la v1.2.10.:
  • changeuserbox
  • header_welcomeblock_member
  • index - Retour à l'original obligatoire, complètement modifié !
  • index_boardstats (rien à faire, je pene que c'est un nouveau template de la 1.2.10)
  • index_logoutlink
  • misc_rules_forum -> pas vu de bouton "Revenir à l'original" ! Changé par l'upgrade ?...
  • showthread_inlinemoderation -> pas vu de bouton "Revenir à l'original" ! Changé par l'upgrade ?...


Donc les templates 1, 2, 3 et 5 premiers sont à revoir !!!

Deux options:
1. Revenir à l'original pour chacun de ces templates dans chacun des thèmes installés.
2. Modifier manuellement pour refléter le nouveau code.

Remarque: la solution 2 est préférable, surtout si vous avez pas mal modifié les templates (ajout de plugins, de thèmes etc...


Choix 1: Revenir à l'original.

Note: Si vous avez des plugins qui ont modifié le code de ces templates, vous les perdrez; il vous faudra sans doute à la fin de la présente opération les désactiver, puis les réactiver tout simplement !

Ouvrez le Panneau d'Administration.
Dans le menu de gauche: Templates > Modifier / Supprimer

Vous obtenez la liste des templates de votre forum.

Il y aura au moins:
Templates généraux
En général vide sauf si vous avez installé des plugins qui ont créé des templates dans cette section...

Default Templates
Ce sont les templates de base (ceux installés par défaut).

Et en plus, autant d'entrées supplémentaires que de thèms installés !!!

Dans "Templates généraux" il n'y a normalement aucun des templates à retoucher...


Dans le bandeau bleu de "Default Templates", cliquez sur le bouton "Voir". Ça peut prendre un peu de temps à répondre selon le nombre de templates installés et la vitesse ou la bande passante de votre serveur...

Dans la liste qui s'ouvre, deux des templates qui nous intéressent se trouvent directement "à la racine"..

Vous devriez voir:
changeuserbox
Cliquez en face sur le bouton "Retour à l'original"

header_welcomeblock_member
Cliquez en face sur le bouton "Retour à l'original"

Pour voir les autres, il faut "développer" l'arborecence.
Cliquez sur Page d'Index Templates ou sur le bouton "Voir" en face.

Dans cette nouvelle page, on va trouver:
index
Cliquez en face sur le bouton "Retour à l'original"

index_logoutlink
Cliquez en face sur le bouton "Retour à l'original"

index_boardstats
misc_rules_forum
se trouvent aussi dans ce groupe, mais pour moi, ils n'avaient pas de bouton "Retour à l'original" ? Modifiés par l'upgrade ? Nouveaux ? Je ne sais pas.. SI vous avez le bouton de "revert", cliquez dessus !

Pour voir le dernier template, cliquez sur "Affichage du sujet Templates" ou sur le bouton "Voir" en face.
showthread_inlinemoderation
est là mais pour moi, sans bouton "Revenir à l'original".


Note: Il faut évidemment répéter toutes les modifications ci-dessus pour chacun des thèmes installés sur votre forum !!!



Choix 2: modifier manuellement le code:

Vous savez maintenant où se trouvent les templates à modifier...
Donc même procédure, mais au lieu de cliquer le bouton "Revenir à l'original", il faut cliquer le bouton "Modifier".

C'est un peu plus ardu comme boulot, mais si vous avez des plugins qui ont inséré du code dans les templates précités, vous ne perdrez pas leur configuration, contrairement à la méthode 1.

Note: Code récupéré par mes soins, donc non complètement garanti... donné sous toutes réserves, ça va de soi...

- pour header_welcomeblock_member
remplacez:
Code:
<a href="{$mybb->settings['bburl']}/member.php?action=logout&uid={$mybb->user['uid']}&sid={$session->sid}">{$lang->welcome_logout}</a>)<br />
par
Code:
<a href="{$mybb->settings['bburl']}/member.php?action=logout&logoutkey={$mybb->user['logoutkey']}">{$lang->welcome_logout}</a>)<br />

- pour changeuserbox
remplacez:
Code:
<a href="{$mybb->settings['bburl']}/member.php?action=logout&uid={$mybb->user['uid']}&sid={$session->sid}">{$lang->change_user}</a>
par
Code:
<a href="member.php?action=logout&logoutkey={$mybb->user['logoutkey']}">{$lang->change_user}</a>

- pour index_logout_link
remplacez
Code:
<a href="{$mybb->settings['bburl']}/member.php?action=logout&uid={$mybb->user['uid']}&sid={$session->sid}">{$lang->index_logout}</a> |
par
Code:
<a href="member.php?action=logout&logoutkey={$mybb->user['logoutkey']}">{$lang->index_logout}</a> |


Là aussi, répéter l'opération pour chaque thème !!!


Voilà, j'espère avoir été clair dans la démarche...


Pour moi, ça fonctionne en local, merci à ceux qui voudront bien tester...

Remarque importante: si vous optez pour la méthode 2, n'oubliez pas quand même de "Revenir à l'orginal" pour le template "index" !!! Ceci est obligatoire !


En espérant vous avoir rendu service...


@+
Spyto

PS: Sacré Chris, il aurait pu prévenir !

PS 2 : Marre de toutes ce MAJ et modifs de templates, vivement que la v1.4 sorte !
On traduira alors ce qui (j'espère) deviendra une version définitive (on peut toujours rêver !)


RE: Déconnexion impossible après mise à jour vers 1.2.10 : une solution... - spyto - 19-12-2007

Oups...

J'ai bossé pour des prunes !!!
Elle était ici la solution
http://community.mybboard.net/showthread.php?tid=25210&pid=177101#pid177101

Pas grave, ça confirme ce que j'ai trouvé: mon code est bon...

A noter que dans ce post c'est la modification "manuelle" qui est choisie.
Je pense que 'est le mieux.

[/b]


RE: Déconnexion impossible après mise à jour vers 1.2.10 : une solution... - LDB - 21-12-2007

Bonjour,

Ba voilà du texte non traduit... "Default Templates"
Bon pour tes explications concernant la 1er méthode, je n'ai aucun bouton "Retour à l'original"

[Image: Templates.jpg]


Pour la méthode 2, effectivement si je compare ton code de changeuserbox au mien il est différent :
Quote:<a href="{$mybb->settings['bburl']}/member.php?action=logout&uid={$mybb->user['uid']}&sid={$session->sid}">{$lang->change_user}</a>
et
Quote:<tr>
<td class="trow1" width="20%"><strong>{$lang->username}</strong></td>
<td class="trow1">{$mybb->user['username']} <span class="smalltext">[<strong><a href="member.php?action=logout&uid={$mybb->user['uid']}&sid={$session->sid}">{$lang->change_user}</a></strong>]</span></td>
</tr>
donc je dois (suivant tes explications) remplacer mon code par le tiens ?
j'attends ta confirmation.

@+

PS: Malgré tout il m'est encore possible de me déconnecter de l'administration mais pas comme membre.


RE: Déconnexion impossible après mise à jour vers 1.2.10 : une solution... - spyto - 21-12-2007

LDB Wrote:Ba voilà du texte non traduit... "Default Templates"

Non, ça ce n'est pas traduit, c'est dans les templates par défaut de MyBB... ça je n'y touche pas pour la traduction!
De plus je ne pense pas qu'on puisse le traduire. Enfin, je verrai !

Quote:Bon pour tes explications concernant la 1er méthode, je n'ai aucun bouton "Retour à l'original"

Bizarre, si tu as fait une MAJ, tu devrais, mais bon...

Quote:donc je dois (suivant tes explications) remplacer mon code par le tiens ?
j'attends ta confirmation.

Je confirme, de plus, c'est la méthode préconisée par le post référencé sur mybbboard.net:
http://community.mybboard.net/showthread.php?tid=25210&pid=177101#pid177101

De toute façon, tu ne risques rien !...
Mais fais bien attention lors du remplacement: ne "mange" pas par exemple un caractère de trop.. fais exactement comme indiqué !
Et pour les 3 templates indiqués dans chaque thème !

@+


RE: Déconnexion impossible après mise à jour vers 1.2.10 : une solution... - LDB - 28-12-2007

Bonjour,
Petite faute de frappe dans "Gestion des utilisateurs/modifier le profil et les paramètres... d'un utilisateur"
dans "Préférences du compte"
Activer la correction de l'hure d'été.
Ch'uis pas za l'hure !

Concernant la modif précédente ça n'a pas marché ou presque pas, je me suis retrouvé effectivement avec la possibilité de me déconnecter mais lors de la reconnexion j'avais uniquement le mot "Déconnexion".
Je retente une nouvelle fois...
@+

Je viens de retenter mais le pb persiste ...

[Image: pb_logout.jpg]
les "Panneau..., Administration..." ont disparu.
le forum n'étant pas encore performant je crois que je vais faire une totale réinstalle.
j'aurais aimé savoir si se pb est dû au fait d'être resté connecté lors de la mise à jour ?

@+

Si quelqu'un voulais bien m'indiquer comment récupérer les membres avec leur mot de passe etc...


 Translation utility provided by Regentronique