1. IMPORTANT : Nouvelles mesures de sécurité - 2. Règles pour obtenir de l'aide dans les forums de support - 3. Restrictions des droits pour le groupe "Support suspendu"

Il est obligatoire de respecter les Règles de MyBB.fr : Version abrégée ou Version complète pour obtenir du support sur nos forums.

Les membres ayant un site/forum contrevenant aux règles de MyBB.support seront placés dans le groupe "Support suspendu" et ne bénéficieront plus du support du staff. Nous recommandons aux autres membres d'agir de même. Il ne s'agit pas d'un bannissement, le membre retrouvera son statut "normal" dès que sa situation sera conforme aux règles.

Nouveau : un Wiki en français : plus de détails.
Avant de soumettre votre problème, consultez-le, ainsi que la FAQ, sans oublier le moteur de recherche interne.


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ATTENTION, gros bugs dans le pack 1.6.7
Tags » attention, bugs, pack, 167
27-05-2012, 15:26,
#1
Exclamation  ATTENTION, gros bugs dans le pack 1.6.7
Je suis en train de préparer les packs 1.6.8 et en faisant des comparaisons de fichiers, je me suis rendu compte que le fichier upgrade17.php avait subi de profondes modifications.
Mais, le rapport de darkside hier soir m'a mis la puce à l'oreille. J'ai eu comme un flash : et si j'avais oublié ces modifs dans la 1.6.7 ?...
Effectivement, c'était le cas !!! Sad

J'ai donc corrigé le fichier et mis l'archive à jour.

Cela n'affecte que les mises à jour depuis 1.4.13 ou 1.4.14 ou inférieur. Ce qui explique sans doute que personne ne l'ait signalé ?... Shy

Comme Darkside n'avait pas fait de mise à jour depuis deux ans il était concerné au premier chef. Sans lui,l'erreur serait passée à l'as.
Un grand merci à lui.

Ci joint le fichier fautif corrige (pour éviter de tout télécharger)

.php   upgrade17.php (Size: 34.19 KB / Downloads: 4)

Non testé, mais darkside dira... Je ne verrouille pas ce sujet pour qu'il puisse répondre et que ce soit plus "visible" qu'au fin fond du forum de rapports.

Je reprécise : ce n'est utile que pour les maj depuis 1.4.14 ou inférieur.

J'espère simplement que vous me pardonnerez pour cete grosse bénue.
Du coup, je vais prendre un peu plus de temps pour créer les archives 1.6.8, je vais vérifier à deux fois. Même si elles sont prêtes, je les mettrai à disposition dans un moment !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
27-05-2012, 17:22, (This post was last modified: 27-05-2012, 17:22 by spyto.)
#2
RE: ATTENTION, gros bugs dans le pack 1.6.7
Et un deuxième gros bug découvert dans upgrade20.php !!!
Il empêche la mise à jour depuis 1.6.x.

En effet la dernière ligne de ce fichier :
PHP Code:
$output->print_footer("19_done"); 
est erronée, ça tourne en rond puisque ce devrait être :
PHP Code:
$output->print_footer("20_done"); 

Là ça va mieux ! Big Grin

En local, je viens de faire un upgrade depuis 1.8.1 vers 1.6.7, ça baigne !

Et même de 1.6.0 à 1.6.8 (en cours de test)

Fichier upgrade20.php de 1.6.7 :

.php   upgrade20.php (Size: 2.71 KB / Downloads: 2)

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
27-05-2012, 17:24, (This post was last modified: 27-05-2012, 17:25 by darkside.)
#3
RE: ATTENTION, gros bugs dans le pack 1.6.7
Hello,

J'ai repris tout le pack pour refaire la mise à jour, à faire autant y aller à fond ^^.

Donc très rapidement, quelques affichages non traduits.
En fait faut percuter vu que c'est en mode redirection auto.

   

   

Il me semble hier, que il n'y avait pas d'oublie de traduction de "updating"

J'aurai espéré que non, mais je tombe sur l'erreur database qu'il faut corriger avec
http://mybb.fr/thread-3364.html

Je trouve étonnant, que ce soit toujours pas corrigé depuis le temps dans le pack de mise à jour mybb.fr officiel ??

Tu as corrigé upgrade 17 mais tu as oublié upgrade20 avec le changement de la variable de 19 à20 à la fin du code Wink

Sinon, j'arrive à la fin ...

   

Avec ce message que j'ai du mal à comprendre...
Mais, ça tiens plus au haut fait que j'y comprend rien en template.

Mais il doit y avoir un rapport avec la tête de la page d'index de mon forum.
   

Le floutage est fait exprès, je suis un peu parano en vie privée Wink
Par contre pour l'apparence du forum, j'ai toujours eu le style de base par défaut.

Je regarderai demain, ce doit être dans un autre sujet, cette histoire.
Reply
27-05-2012, 18:20,
#4
RE: ATTENTION, gros bugs dans le pack 1.6.7
Pour les textes non traduits c'est corrigé.
En fait, je me traîne ces erreurs dans upgrade17.php et upgrade 20.php depuis la v1.6.4 !!! ShyShyShyShy

Why ???????????

Bref, j'ai tout corrigé depuis la 1.6.4, recréé les archives et remis à jour sur le serveur.
Je pense que là tout est OK ?
J'ai mal à la tête à force.
Je termine la 1.6.8 et je la poste à des fins de test0
J'en ai ma claque depuis ce matin, ça suffira pour aujourd'hui ! Rolleyes

Pour ton problème d'affichage c'est normal quand on vient d'une trop vieille version !
Il te suffit (je pense) de faire :
Admin > Thèmes (dans le menu de gauche) puis de cliquer sur ton thème > Options > Supprimer/Rétablir.
Tu verras que ça ira beaucoup mieux !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
27-05-2012, 18:45, (This post was last modified: 27-05-2012, 19:03 by darkside.)
#5
RE: ATTENTION, gros bugs dans le pack 1.6.7
Hello,

Bon ça va, je suis pas le seul à saturer Wink ...
Tu as raison, ça va beaucoup mieux pour le thème, merci Big Grin

Pour l'instant je laisse le forum clone à cette version, histoire de faire le tour.... des nouveautés mods etc... et voir si utile ou non d'upgrader le forum originel.
Ensuite si oui j'effacerai, et referai une dernière installation de clone avec la dernière version.
Et si tout marche, maj pour de vrai sur mon fofo...

En attendant, je dit ou pas ??? mmmmmm MMMM mmmmm

D'abors je sors un jaune, et t'en propose un ...

Ensuite, pour demain, petite erreur je croie..

Cela vient du système de réputation... dommage que pas actif sur ton forum, j'aurai pu vérifier sans te déranger..

Que l'on veuille consulter ou editer, bref y accéder sur le profil d'un membre, on tombe sur une classique et horrrrrrriiiible

Parse error: syntax error, unexpected T_VARIABLE in mondomaine/clone/inc/languages/french/reputation.lang.php on line 29

Bon repos, je laisse tomber, je continuerai à fouiner demain Wink

Edit: je confirme, c'est pas le script de réputation... en métant us en option language, ça marche.
Reply
27-05-2012, 18:59,
#6
RE: ATTENTION, gros bugs dans le pack 1.6.7
Oui là c'est vrai que je sature !...

Voilà c'est corrigé. Va savoir comment et pourquoi un foutu '0' est allé se glisser en fin de ligne 28 de ce foutu fichier. Frappe intempestive et involontaire.. mais PHP ne pardonne rien !

Je te mets le fichier là :

.php   reputation.lang.php (Size: 5 KB / Downloads: 1)
bien que je me doute que tu es capable d'enlever ce zéro tout seul ! Tongue

Archives corrigées et réuploadées.
(évidement la ligne erronée s'était reportée dans la 1.6.8 !)

Voilà, rideau pour aujourd'hui ! J'y aurai passé le plus clair de mon temps !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
27-05-2012, 19:06, (This post was last modified: 27-05-2012, 19:18 by darkside.)
#7
RE: ATTENTION, gros bugs dans le pack 1.6.7
bien que je me doute que tu es capable d'enlever ce zéro tout seul !.
euh en fait oui et non...

Pour des raisons pratique, c'est mieux un éditeur qui numérôte les lignes pour l'édition...
Mais jamais réussi à en trouver gratuit, léger et facile, que des usines à gaz.
Donc je fais au bloc note de base et compter les lignes c'est chiant Sad


Mais si tu as un conseil Wink

Nb:
Par contre avec moi, te prend la tête à mettre le fichier en pj, je peux aller le chercher directement dans le pack à jour Big Grin , ça fera un opé de moins.
Reply
27-05-2012, 19:16,
#8
RE: ATTENTION, gros bugs dans le pack 1.6.7
Le bloc-notes de Windows est fortement déconseillé ! Il insère des signes cabalistiques quand on enregistre en UTF-8. En fait, il ne "sais pas faire" UTF-8 sans BOM.

Dans le gratuit tu as Notepad++ ou Hapedit qui sont bien.
Ils apportent le "plus" de la coloration syntaxique qui rend l'édition de PHP/HTML (entre autres) bien plus aisée.
Mais là je dévie du sujet... Tongue


[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
28-05-2012, 10:32,
#9
RE: ATTENTION, gros bugs dans le pack 1.6.7
Kikoo,

Merci pour tes liens, après un rapide test, notepad++ semble mieux me convenir en convivialité Big Grin

C'est un peu HS, mais je pense que tu peux fermer, je vais passer du 1.6.7 au 1.6.8 pour voir... car si coquilles en 1.6.7 on va les retrouver en 1.6.8 Wink
Reply
28-05-2012, 13:41,
#10
RE: ATTENTION, gros bugs dans le pack 1.6.7
(28-05-2012, 10:32)darkside Wrote:  car si coquilles en 1.6.7 on va les retrouver en 1.6.8 Wink
J'espère bien que non ! J'ai reporté dans 1.6.8 les corrections des coquilles que tu m'as signalées.

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply
01-06-2012, 15:29,
#11
RE: ATTENTION, gros bugs dans le pack 1.6.7
Bugs corrigés, je retire l'épingle...

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Reply




Users browsing this thread: 1 Guest(s)

Contact Us | MyBB.support | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication
 Translation utility provided by Regentronique