1. IMPORTANT : Nouvelles mesures de sécurité - 2. Règles pour obtenir de l'aide dans les forums de support - 3. Restrictions des droits pour le groupe "Support suspendu"

Il est obligatoire de respecter les Règles de MyBB.fr : Version abrégée ou Version complète pour obtenir du support sur nos forums.

Les membres ayant un site/forum contrevenant aux règles de MyBB.support seront placés dans le groupe "Support suspendu" et ne bénéficieront plus du support du staff. Nous recommandons aux autres membres d'agir de même. Il ne s'agit pas d'un bannissement, le membre retrouvera son statut "normal" dès que sa situation sera conforme aux règles.

Nouveau : un Wiki en français : plus de détails.
Avant de soumettre votre problème, consultez-le, ainsi que la FAQ, sans oublier le moteur de recherche interne.


Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
MyBB 1.8.19 - Tous les packs [17-09-2018]
Mots-clés » mybb, 1819, packs, 17-09-2018
17-09-2018, 16:55,
#1
MyBB 1.8.19 - Tous les packs [17-09-2018]
Comme d’habitude, je vous livre tous les packs. Merci pour les rapports de bugs ! Smile

Faut croire qu'il y avait le feu ! La v1.8.18 est sortie le 22-08-18 et voilà la v1.8.19 qui sort le 11 septembre (date fatidique !). Trois semaines après, c'est un record !

Les mises à jour sont de plus en plus fréquentes. D'un côté ça prouve qu'ils travaillent, mais d’un autre on peut craindre qu'ils publient trop tôt avant d'avoir déniché les bugs... ou d'en avoir créé de nouveaux ! Sans doute colmatent-ils les brèches ? Je veux bien sûr parler des "développeurs" de mybb.com. Tongue

J'ai testé :
- installation "neuve" 1.8.19 => OK
- maj de 1.8.18 => OK
- maj de 1.6.x => NON TESTÉ
Pour vos remarques et rapports, voir en fin de message. Merci pour vos futurs rapports de bugs, en espérant qu'il y en ait le moins possible !

FAITES DES TESTS SUR UN FORUM NON EN PRODUCTION SVP le temps de dénicher les bugs éventuels.

Une sauvegarde de la base et des fichiers (pour se réserver une porte de sortie en cas d'erreur ou de fausse manip) est toujours fortement recommandée.

MyBB 1.8.19 – Mise à jour de sécurité et de maintenance
Cette mise à jour améliore la compatibilité avec PostgreSQL et résout les régressions des versions précédentes. Les administrateurs peuvent devoir mettre à jour le code CSS dans global.css pour des thèmes personnalisés.

Avant d'effectuer toute mise à jour, n'oubliez pas de sauvegarder les fichiers de votre forum et la base de données et de les stocker en un lieu sécurisé. Si vous avez modifié des fichiers de base, y compris les fichiers de langues, assurez-vous de faire un journal de ces modifications afin de pouvoir les reporter à nouveau (si nécessaire) une fois que la mise à niveau est terminée.

Pour mettre à jour, suivez le processus de mise à niveau.

Vous devez exécuter le script de mise à jour pour cette version.
  • 4 failles de sécurité abordées :
    • Risque élevé:  champ Email SQL Injection - rapporté par StefanT
    • Risque moyen:  Vidéo MyCode XSS persistant dans l'éditeur visuel - rapporté par Numan OZDEMIR de InfinitumIT
    • Risque faible: la vérification de permission insuffisante dans la gestion des pièces jointes de CP utilisateur - rapporté par StefanT
    • Risque faible: vérification de l'adresse e-mail insuffisante - rapporté par StefanT
  • 8 problèmes corrigés

Détails de la mise à jour

Fichiers modifiés (83)
  • admin/
    • modules/
      • user/
        • users.php
  • inc/
    • datahandlers/
      • user.php
    • class_core.php
    • functions.php
    • functions_archive.php
    • functions_forumlist.php
    • functions_search.php
    • functions_user.php
  • install/
    • resources/
      • language.lang.php
      • mybb_theme.xml
      • pgsql_db_inserts.php
      • upgrade46.php
    • index.php
  • jscripts/
    • bbcodes_sceditor.js
  • editpost.php
  • misc.php
  • newreply.php
  • newthread.php
  • usercp.php
Templates modifiés (2)
  • codebuttons
  • post_subscription_method

Mise à jour depuis 1.8.18 et autres versions. Si vous utilisez MyBB 1.8.18 version complète bilingue (téléchargée ici) :
Si vous utilisez MyBB 1.8.19 version anglaise (téléchargée sur mybb.com) :
Si vous utilisez MyBB 1.8.17 ou inférieur ou pour une installation nouvelle :
Dans le cas où vous avez déjà installé MyBB 1.8.19 en version anglaise et que vous voulez le "franciser", vous pouvez utiliser le pack de langue 1.8.17.
Téléchargez et utilisez le pack de langue 1.8.19
(les instructions sont incluses dans l'archive en anglais et en français)
D'après les "spécialistes", aucun fichier de langue n'est changé... ce qui est vrais, mais dans /inc/languages/french.php et english.php, ils ont oublié de mettre à jour
Code :
$langinfo['version'] = "1819";
... ce qui est peut-être voulu... mais ça m'étonnerait !

Rapportez les bugs ou coquilles ici : http://mybb.support/thread-7030.html

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~




Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

Contact | MyBB.support | Retourner en haut | Retourner au contenu | Version bas-débit (Archivé) | Syndication RSS
Utilitaire de traduction fourni par Regentronique