1. IMPORTANT : Nouvelles mesures de sécurité - 2. Règles pour obtenir de l'aide dans les forums de support - 3. Restrictions des droits pour le groupe "Support suspendu"

Il est obligatoire de respecter les Règles de MyBB.fr : Version abrégée ou Version complète pour obtenir du support sur nos forums.

Les membres ayant un site/forum contrevenant aux règles de MyBB.support seront placés dans le groupe "Support suspendu" et ne bénéficieront plus du support du staff. Nous recommandons aux autres membres d'agir de même. Il ne s'agit pas d'un bannissement, le membre retrouvera son statut "normal" dès que sa situation sera conforme aux règles.

Nouveau : un Wiki en français : plus de détails.
Avant de soumettre votre problème, consultez-le, ainsi que la FAQ, sans oublier le moteur de recherche interne.


Note de ce sujet :
  • Moyenne : 4.5 (2 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Rapports traduction 1.8 fr
Mots-clés » rapports, traduction
21-12-2016, 21:30, (Modification du message : 21-12-2016, 21:31 par Pichorka.)
RE: Rapports traduction 1.8 fr
(21-12-2016, 18:09)Pichorka a écrit :  J'ai également lu qu'il faudrait ajouter également ceci :


Citation :"Rappelez - vous: un type HTTP> HTTPS redirection est intrinsèquement précaire et fait relativement peu pour sécuriser vos utilisateurs. Vous devez également envoyer un en- tête de HSTS via HTTPS avec:


Code PHP :
Header set Strict-Transport-Security "max-age=31536000" env=HTTPS 


Cela fera que les navigateurs se souviennent de se connecter uniquement via HTTPS _avant_ toutes les données sont envoyées.

Démarrez l'âge maximum à quelque chose de bas comme 86400 (1 jour) avant que vous avez confirmé que les choses sont prêts à 100%. Ensuite , travailler votre chemin jusqu'à la valeur de 1 an dans l'extrait. Cette étape est la suivante la plus critique."
Sujet > https://community.mybb.com/thread-205538-post-1251926.html#pid1251926

Je dois avouer que je n'ai pas régler tous les problèmes, que la ligne pour forcer le https cité au dessus semble sans effet vu que je ne sais pas ou la placer ...

J'ai besoin de vos savoirs pour faire une transition propre, si vous le voulez bien, parce que je 'sèche' un peu tout de même, bref je nage dans l'inconnu total :s

Merci par avance, avec respect !

Merci Exdiogene je l'avais lu mais 40$ par an IP + SSL chez qui ?

Ensuite j'ai bien le https mais c'est toujours le http qui est actif je ne sais pas comment l'enlever ou obliger a aller sur le https http://www.mobilsam.com ça pointe toujours sur le http://www.mobilsam.com

Je ne sais pas comment faire pourriez vous m'"aiguiller" vers la vrai et bonne solution, je n'ai plus de cheveux en 4 heures :s ?

Merci a vous Smile
Répondre
23-12-2016, 0:34,
RE: Rapports traduction 1.8 fr
SOLUTION

Mettre ceci dans le .htaccess

Code PHP :
RewriteEngine On
RewriteCond 
%{HTTPS} !=on
RewriteRule 
https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] 

Ca pourra servir à d'autres Smile
Répondre
12-11-2017, 12:28,
RE: Rapports traduction 1.8 fr
Bonjour,

Parse error: syntax error, unexpected 'Nous' (T_STRING) in [j'ai effacé le début]/www/forum/inc/languages/french/admin/config_settings.lang.php on line 130

Beaucoup de lignes semblent avoir ce problème:
130, 131, 169, 217, 259, etc etc
Bref partout où il y a un double slash. La solution est de le remplacer par un slash simple, par exemple à la ligne 664 ça donne:

$l['setting_mail_parameters_desc'] = "Ce paramètre vous permet de déterminer des réglages supplémentaires pour la fonction PHP mail(). Utilisé seulement quand \"PHP mail\" est sélectionné comme gestionnaire de messagerie. <a href=\"http://fr2.php.net/function.mail\" target=\"_blank\" rel=\"noopener\">Plus d’informations</a>";

L'idéal serait de faire:
$l['setting_mail_parameters_desc'] = 'Ce paramètre vous permet de déterminer des réglages supplémentaires pour la fonction PHP mail(). Utilisé seulement quand \"PHP mail\" est sélectionné comme gestionnaire de messagerie. <a href="http://fr2.php.net/function.mail" target="_blank" rel="noopener">Plus d’informations</a>';

Puisque la phrase est entourée de guillemets simples on peut utiliser les doubles pour l'URL. Mais j'ai constaté qu'en remplacant simplement les \\ par \ les liens fonctionnent quand même.

Bonne journée Smile
Répondre
12-11-2017, 12:56,
RE: Rapports traduction 1.8 fr
(12-11-2017, 12:28)mmfr2ooo a écrit :  Bonjour,

Parse error: syntax error, unexpected 'Nous' (T_STRING) in [j'ai effacé le début]/www/forum/inc/languages/french/admin/config_settings.lang.php on line 130

Beaucoup de lignes semblent avoir ce problème:
130, 131, 169, 217, 259,  etc etc
Bref partout où il y a un double slash. La solution est de le remplacer par un slash simple, par exemple à la ligne 664 ça donne:

$l['setting_mail_parameters_desc'] = "Ce paramètre vous permet de déterminer des réglages supplémentaires pour la fonction PHP mail(). Utilisé seulement quand \"PHP mail\" est sélectionné comme gestionnaire de messagerie. <a href=\"http://fr2.php.net/function.mail\" target=\"_blank\" rel=\"noopener\">Plus d’informations</a>";

L'idéal serait de faire:
$l['setting_mail_parameters_desc'] = 'Ce paramètre vous permet de déterminer des réglages supplémentaires pour la fonction PHP mail(). Utilisé seulement quand \"PHP mail\" est sélectionné comme gestionnaire de messagerie. <a href="http://fr2.php.net/function.mail" target="_blank" rel="noopener">Plus d’informations</a>';

Puisque la phrase est entourée de guillemets simples on peut utiliser les doubles pour l'URL. Mais j'ai constaté qu'en remplacant simplement les \\ par \ les liens fonctionnent quand même.

Bonne journée Smile

Merci beaucoup !

Effectivement, je n'avais pas revérifié ce fichier.
Je le construis à l'aide d'un script à partir du fichier "settings.xml".
Or j'avais égaré ce script, je l'ai récrit, mais j'ai oublié de traiter le cas des double antislash.

J'ai corrigé ce fichier config_settings.lang.php et j'ai reconstruit et réuploadé les archives.
Dites-moi si avec le fichier ci-dessous c'est bon...

.php   config_settings.lang.php (Taille : 82.27 Ko / Téléchargements : 2)

Merci

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
12-11-2017, 13:23,
RE: Rapports traduction 1.8 fr
De rien Smile
Oui cette fois c'est bon.

Merci pour votre travail à chaque nouvelle mise à jour.

Bonne journée
Répondre
12-11-2017, 13:51,
RE: Rapports traduction 1.8 fr
J'ai encore modifié les deux fichiers :
- /inc/languages/french/admin/config_settings.lang.fr
- /install/resources/settings.xml
car j'avais oublié de modifier qqs détails par rapport au fichier anglais.

Avant que je ne reconstruise les archives et que je ne réuploade le tout, auriez-vous l'amabilité de tester l'installation neuve et la mise à jour avec les deux fichiers ci-dessous ?

.xml   settings.xml (Taille : 135.61 Ko / Téléchargements : 5)

.php   config_settings.lang.php (Taille : 82.22 Ko / Téléchargements : 4)

Merci

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
30-12-2018, 14:27, (Modification du message : 30-12-2018, 14:34 par jordan.)
RE: Rapports traduction 1.8 fr
Bonjour,

Une faute de frappe:
[Image: jitdB8SKRByT5v7XT5x6qA.png]

Et par défaut ici il n'y a pas d'espace (je l'ai rajouté moi même):
[Image: gY1DUmQITxm7yrIwZVd6oQ.png]

Si on met on point partout, il en manque 2:
[Image: XCX9xlXoS4G8-ZrP79H8rg.png]

Bonne journée Smile
Répondre
30-12-2018, 15:34,
RE: Rapports traduction 1.8 fr
Désolé, mais je ne vois aucune image ! Undecided

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
30-12-2018, 15:37,
RE: Rapports traduction 1.8 fr
J'en vois une (pièce jointe), mais c'est tout...


Pièces jointes Miniature(s)
   

Cordialement,
Saphir,
Modérateur MyBB.support.
Répondre
30-12-2018, 17:33,
RE: Rapports traduction 1.8 fr
(30-12-2018, 14:27)jordan a écrit :  Bonjour,

Une faute de frappe:
[Image: jitdB8SKRByT5v7XT5x6qA.png]

Et par défaut ici il n'y a pas d'espace (je l'ai rajouté moi même):
[Image: gY1DUmQITxm7yrIwZVd6oQ.png]

Si on met on point partout, il en manque 2:
[Image: XCX9xlXoS4G8-ZrP79H8rg.png]

Bonne journée Smile

Je viens de comprendre pourquoi parfois je ne vois pas les images ajoutées dans les messages, c'est parce qu'elle sont précédées par "https://" au lieu de "http://".

Mais je ne comprends toujours pas pourquoi Saphir en voit une?

Voici les trois images corrigées, mais comme Saphir on en voit qu'une :
[Image: jitdB8SKRByT5v7XT5x6qA.png]
[Image: gY1DUmQITxm7yrIwZVd6oQ.png]
[Image: XCX9xlXoS4G8-ZrP79H8rg.png]

Voici donc les trois images en lien :
http://image.prntscr.com/image/jitdB8SKRByT5v7XT5x6qA.png
http://image.prntscr.com/image/gY1DUmQITxm7yrIwZVd6oQ.png
http://image.prntscr.com/image/XCX9xlXoS4G8-ZrP79H8rg.png

Mais curieusement nous ne voyons que la dernière, lorsque précédemment je pouvais voir les trois? Huh

Administrateur de MyBBCodes.com
Cool " Ce n'est pas ce que vous savez qui est important, c'est ce que vous faites ou ne faites pas!"
Obtenez plus de 175 plugins pour MyBB ici...
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
30-12-2018, 17:35,
RE: Rapports traduction 1.8 fr
En HTTP je n'en vois plus aucune :'D

Cordialement,
Saphir,
Modérateur MyBB.support.
Répondre
30-12-2018, 17:43,
RE: Rapports traduction 1.8 fr
C'est donc curieux!

Je peux toujours voir la troisième image en http et en lien...

Toi Spyto, que vois-tu?

@Saphir : Ne vois-tu pas l'image du troisième lien "http://image.prntscr.com/image/XCX9xlXoS4G8-ZrP79H8rg.png"

Administrateur de MyBBCodes.com
Cool " Ce n'est pas ce que vous savez qui est important, c'est ce que vous faites ou ne faites pas!"
Obtenez plus de 175 plugins pour MyBB ici...
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
30-12-2018, 19:47, (Modification du message : 30-12-2018, 19:48 par spyto.)
RE: Rapports traduction 1.8 fr
Pour moi, c'est rien !

Même avec les liens fournis, j'ai une page 403 Forbidden.

Et je ne vois aucune pièce jointe non plus.

Edit : je vois la pj du message de Saphir, uniquement !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
30-12-2018, 20:05,
RE: Rapports traduction 1.8 fr
C'est donc curieux, moi je n'ai le message "403 Forbidden" que pour les deux premiers liens!

Alors je crois que le problème vient du site fournissant les images, il doit donner des résultats différents à différents navigateurs web, car les réponses sont consistantes dans le temps chez moi.

Moi j'ai FireFox 64.0 (64 bits) tout comme toi Spyto, je ne comprends pas les différences entre nous, sauf si la geo-localisation est en oeuvre ou l'identification IP...

Je viens de découvrir que les liens https fonctionnent maintenant :

https://image.prntscr.com/image/jitdB8SKRByT5v7XT5x6qA.png
https://image.prntscr.com/image/gY1DUmQITxm7yrIwZVd6oQ.png
https://image.prntscr.com/image/XCX9xlXoS4G8-ZrP79H8rg.png

Administrateur de MyBBCodes.com
Cool " Ce n'est pas ce que vous savez qui est important, c'est ce que vous faites ou ne faites pas!"
Obtenez plus de 175 plugins pour MyBB ici...
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
30-12-2018, 20:08, (Modification du message : 30-12-2018, 20:11 par spyto.)
RE: Rapports traduction 1.8 fr
Pour moi, les 3 c'est 403 Forbidden (Firefox 64)

Edit : avec Edge, c'est pareil !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
30-12-2018, 22:22,
RE: Rapports traduction 1.8 fr
Maintenant les 3 images originales de Jordan sont apparues dans son message, c'est à ne rien y comprendre... Sad

http://mybb.fr/thread-7030-post-46938.html#pid46938

Administrateur de MyBBCodes.com
Cool " Ce n'est pas ce que vous savez qui est important, c'est ce que vous faites ou ne faites pas!"
Obtenez plus de 175 plugins pour MyBB ici...
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
31-12-2018, 10:53,
RE: Rapports traduction 1.8 fr
Pour moi, c'est toujours pareil !

Ce que je vois dans son message :
Citation :Une faute de frappe:
[Image: jitdB8SKRByT5v7XT5x6qA.png]

Et par défaut ici il n'y a pas d'espace (je l'ai rajouté moi même):
[Image: gY1DUmQITxm7yrIwZVd6oQ.png]

Si on met on point partout, il en manque 2:
[Image: XCX9xlXoS4G8-ZrP79H8rg.png]

Pourtant, si j'édite son post, le code source semble correct :
Code PHP :
Une faute de frappe:
[
img]https://image.prntscr.com/image/jitdB8SKRByT5v7XT5x6qA.png[/img]

Et par défaut ici il n'y a pas d'espace (je l'ai rajouté moi même):
[img]https://image.prntscr.com/image/gY1DUmQITxm7yrIwZVd6oQ.png[/img]

Si on met on point partout, il en manque 2:
[img]https://image.prntscr.com/image/XCX9xlXoS4G8-ZrP79H8rg.png[/img] 
sauf que c'est du https://...

Et dans le tien où tu donnes les liens :
Citation :Voici donc les trois images en lien :
http://image.prntscr.com/image/jitdB8SKRByT5v7XT5x6qA.png

http://image.prntscr.com/image/gY1DUmQITxm7yrIwZVd6oQ.png
http://image.prntscr.com/image/XCX9xlXoS4G8-ZrP79H8rg.png

Ces 3 liens aboutissent pour moi à une page blanche : 403 Forbidden - nginx

Effectivement, c'est à n'y rien comprendre !

[Image: spyto.png]
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre
31-12-2018, 15:30,
RE: Rapports traduction 1.8 fr
Il est possible que le site prntscr.com soit sur le "cloud" ayant différents caches mis-à-jour à différents moments!

Ce serait encore une fois la preuve de la non-efficacité du "cloud"...

Après avoir vérifier, voici la réponse : "prntscr.com is using Cloudflare CDN/Proxy! "

IP : 104.20.14.105
NS1 : dave.ns.cloudflare.com
NS2 : jill.ns.cloudflare.com

Administrateur de MyBBCodes.com
Cool " Ce n'est pas ce que vous savez qui est important, c'est ce que vous faites ou ne faites pas!"
Obtenez plus de 175 plugins pour MyBB ici...
~~ AUCUNE AIDE Par MP, MAIL OU MSN !!!~~
Répondre




Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

Contact | MyBB.support | Retourner en haut | Retourner au contenu | Version bas-débit (Archivé) | Syndication RSS
 Utilitaire de traduction fourni par Regentronique